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Introduction to Topaz Workbench
Eclipse Development Environment
Topaz Workbench is a modernized Eclipse-based development environment and an alternative to TSO/ISPF,
enabling developers from a variety of technical backgrounds to be productive in a mainframe environment more
quickly. It provides a common framework and integrated user interface from which to initiate Compuware’s mainframe
products as well as non-Compuware and distributed products. Most IT organizations already use Eclipse for
application development on non-mainframe technologies. Eclipse is ubiquitous in the industry as colleges and trade
schools use it for its sophistication and no-cost availability.
Topaz Workbench can be run as a standalone Eclipse application or as a set of plug-ins that can be added directly to
existing Eclipse developments or other Eclipse-based software such as IBM’s RDz.

Topaz Innovation
Topaz is Compuware’s newest and highly innovative solution that empowers IT organizations to preserve and
advance their mainframe investments. Topaz's elegant simplicity in design and usability helps a new mainframe
development workforce quickly understand, update, maintain, and troubleshoot even the oldest, most complex,
and/or most poorly documented systems.
Topaz for Program Analysis
Program Analysis intelligently analyzes mainframe programs and presents the results of that analysis in a visually
intuitive manner using program structure and logic flow charts. Program Analysis reduces learning curves for
programmers unfamiliar with the mainframe or unfamiliar with the structure of a program.

Program Analysis also includes Runtime Visualizer, a feature that provides unprecedented
graphical visibility into complex interactions between mainframe programs. This visibility makes
it easy for veteran and novice developers alike to quickly understand, update, and troubleshoot
even the oldest and most complex mainframe code.
Topaz for Enterprise Data
Enterprise Data enables mainframe developers and mainframe data architects to discover, visualize, and work with
both mainframe and non-mainframe data in a common, intuitive manner. Using Topaz, next-gen mainframe
developers as well as seasoned IT pros can manipulate Enterprise Data and applications with greater agility, speed,
and confidence to better meet the demands of mobile and analytics.
Edit Data with a Single Enterprise Editor - Source-specific tools to browse and edit data are no longer needed for
mainframe development. Topaz Workbench’s Enterprise Data Editor features a single intuitive user interface to
manage Oracle, SQL Server, IMS, DB2, and other data types across the enterprise.
Visualize Data Relationships - Many times developers struggle to understand the complex relationships among their
enterprise data. Now users can visually manage vast quantities of data objects using Topaz's Data Visualizer, a
graphical representation of data relationships across the enterprise. This feature is especially useful when extracting
data for testing purposes.
With Data Visualizer, you can create, view, manipulate, export, and print graphical representations of data objects and the
relationships between them.

Base Functionality within Topaz Workbench
Topaz Workbench brings the power of Compuware’s world-class products to IT staff of all experience levels.
Technicians can flow seamlessly from task to task while developing and maintaining a complex mix of cross-platform
applications. Behind the user interface are the same Compuware mainframe products that have provided solid,
reliable value for decades—Abend-AID, File-AID, Hiperstation, Xpediter, and Strobe. The intuitive and easy-to-use
interfaces provide the essentials of software development, testing, and maintenance:
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•
•
•
•
•
•

Fault diagnosis
Data browse and edit: Sequential, indexed, VSAM, DB2, IMS, and z/OS UNIX
Advanced data and source search
Interactive debugging: Mainframe-hosted COBOL, PL/I, C language, and HLASM
Application performance tuning and analysis
Audit reporting

Additionally, Topaz Workbench reaches beyond the traditional Compuware mainframe development functionality
listed above and provides a framework that delivers additional ISPF-like functionality, including:

•
•
•
•

Source code edit
Invocation of mainframe compiler
JES functions: Job submission, review, print, purge
Dataset management (such as allocation, compression, deletion)

This means that much of what happens in a “day in the life of a mainframe programmer” can be done within Topaz
Workbench.
Compuware provides a comprehensive API that allows custom capabilities to be directly integrated into the
development environment. Developers can focus on the task at hand rather than on which tool or command they
need to use to get the job done.
This Topaz Workbench contains a base set of features that are enabled automatically for existing users of the Compuware
mainframe tools.
Window to the Mainframe with HOST EXPLORER
Easily conduct core tasks, such as:

•
•
•
•

Navigate mainframe datasets, network and local file structures; create, rename and delete files.
Create, edit, browse, save, rename, delete, move, copy, and compress datasets and PDS members and
copy data across LPARs.
Submit JCL and view held output.
Catalog and uncatalog datasets; recall or delete migrated datasets; manipulate Compuware DDIO files.

Refer to the Topaz Workbench Host Explorer User Guide for more information on configuring and using the Host
Explorer feature.
Debugging with XPEDITER
Debugging capabilities for batch, CICS, IMS MPP, and DB2 Stored Procedures. Functionality includes:

•
•
•

The power of Xpediter debugging within the Eclipse debugging framework
Cross LPAR Shared IMS Queue Support and cross-LPAR debugging
Enhanced navigation and the ability to retain breakpoints across debugging sessions

Integration with Atlassian JIRA enables users to log faults and performance problems found via Abend-AID and
Strobe with the information to automatically create an Xpediter debug configuration.
Refer to the Topaz Workbench Xpediter/Eclipse User Guide for more information.
Measure Testing Efficiency with CODE COVERAGE
Measure testing efficiency and risk metrics for mainframe programs:

•
•

Display results and drill down to annotated listing.
Quickly access testing efforts, percentage code tests, and relative risk of changed code.
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Refer to the Topaz Workbench Code Coverage/Eclipse User Guide for more information.
Powerful Data Access with FILE-AID
Extensive browse, edit, and search capabilities of data:

•
•
•
•
•

Manipulate Sequential, DB2, VSAM, IMS, compressed data, and z/OS UNIX.
Common “data is data” spreadsheet look and feel for all data types; single-table edit and browse; highlighted
find/replace.
Enhanced navigation, bookmarking, and data status indicators
Powerful data filtering (Selection Criteria) capabilities, with provisions to save and reuse requests
XREF support

Refer to the Topaz Workbench File-AID/Eclipse User Guide for more information.
Intelligent Source Code Editor
This powerful, multi-language, multi-platform, source code editor streamlines the creation and maintenance of
application programs. Language-specific aids are available for mainframe COBOL, PL/I, HLASM, and C Language.
Additionally, this editor can emulate several other industry-standard editors, including ISPF.
Refer to the SlickEdit Core for Eclipse help for more details.
Integration with SonarLint with Topaz Workbench enables developers to rapidly delivery quality COBOL by providing
them with automated on-the-fly quality and standards checking with the toolset that is already a standard for technical
debt management across a wide range of technologies. SonarLint is produced by SonarSource, the same company
that drives the industry leading SonarQube quality platform that helps large enterprises optimize their agility across
both mainframe and non-mainframe platforms.
Hiperstation Application Auditing
Graphical interface to the Hiperstation application auditing log analysis and review facilities.
Refer to the Topaz Workbench Hiperstation/Eclipse User Guide for more information.
Abend-AID, iStrobe, and Fault Analytics Plug-Ins
This collection of plug-ins allows licensed users to launch Abend-AID, iStrobe, and Fault Analytics.
For more info on configuring and using the Mainframe Tool Access Plug-ins, from the Help menu, select the
following:

•
•
•

Topaz Workbench Abend-AID User Guide
Topaz Workbench iStrobe User Guide
Topaz Workbench Fault Analytics User Guide

Compuware Host Services SDK
The Host Services SDK includes the Host Services API along with developer resources such as examples, an
examples template, code snippets, and Javadoc. The Host Services API provides users with methods to
programmatically access and perform dataset and JES operations, as well as launch and communicate with z/OS
programs.
Refer to the Compuware Host Services SDK help for more details.
File-AID Data Privacy
The File-AID Data Privacy plug-in facilitates the definition of test data disguise projects. The plug-in requires Topaz
Workbench and provides a GUI interface to create "disguise rules" and a central "rules repository" to contain them.
3
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The "dynamic privacy rules" can be applied from File-AID products to disguise personal identification information
when creating test data for mainframe or distributed databases.
The File-AID Data Privacy plug-in is installed with the Topaz Workbench to facilitate the definition of data privacy
projects. The plug-in requires Topaz Workbench and provides a GUI interface to create disguise rules and a central
rules repository to contain them. The dynamic privacy rules can be applied from File-AID products to disguise
personal identification information for mainframe or distributed data.
Refer to the Topaz Workbench File-AID Data Privacy User Guide for more information
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Compuware Menu
A top-level menu, Compuware, is provided to enable easy access to the various plug-ins (features). Selecting an
item from this menu is equivalent to opening the perspective corresponding to the listed item.
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Companion Product Compatibility
To work with mainframe data, Topaz Workbench requires connection to a z/OS host that contains at least one
licensed Compuware mainframe product. If the selected host does not have a valid Compuware mainframe license,
an error message appears.
Further, when a user first logs in to a mainframe host, a check is performed to validate the presence and versions of
several Compuware products (such as CSS and File-AID) that are configured for the host connection. Status
messages are written to the Console view. Refer to the Topaz Workbench Host Explorer User Guide for information
on the Console view.
For information about Topaz Workbench companion product requirements, go to the Compuware Support Center
at https://go.compuware.com.
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Configuring Host Connections
Before you can use the Host Explorer to interact with the mainframe, you will need to have a Host Connection
configured.
Topaz Workbench's central administration functionality allows users to easily synchronize host connection settings
with Compuware Enterprise Services (CES). Topaz Workbench monitors these settings, which are stored in CES,
and notifies the user when changes have occurred so the user can synchronize to the CES settings.
Alternatively, some sites may stage the host connections preferences so that you can import them and start working
with hosts quickly after installing Topaz Workbench.
To configure host connections

If host connections preferences are not provided, in the Host Explorer view, right-click Hosts and select Configure.
The Host Connections configuration preference dialog box appears. Details on host configuration for Host Explorer
are provided in the Topaz Workbench Host Explorer User Guide.

Central Administration of Connection and Configuration Settings
Topaz Workbench's central administration functionality allows users to easily synchronize host connection settings;
Abend-AID, Fault Analytics, iStrobe, and other configuration settings; and p2 repo update sites with Compuware
Enterprise Services (CES). This allows Topaz Workbench to monitor these settings, which are stored in CES, and
notify the user when changes have occurred so the user can synchronize to the CES settings.
To enable synchronization notifications

1.

Start Topaz Workbench. The Compuware Enterprise Services Synchronization dialog box appears
asking whether to synchronize host connection settings and other configuration settings with CES now. This
message does not appear if a CES URL was not entered during Topaz Workbench installation or on the
Enterprise Services preferences page after installation, or if the user previously clicked Never on the
Compuware Enterprise Services Synchronization dialog box.
Note: If the Compuware Enterprise Services (CES) server has been set up to
require credentials for authentication, the Compuware Enterprise Services Login
dialog box appears when Topaz Workbench is first started. However, this dialog box will
not appear if the user previously opted to save credentials or is already logged in for the
current Topaz Workbench session. After logging in, the Compuware Enterprise
Services Synchronization dialog box appears as described above.

2.

Click Now to synchronize the host connection settings and other configuration settings now and to display a
notification the next time Topaz Workbench is launched and there are updated settings to be synchronized.
The Synchronize Remote HCI Connections dialog box appears.
Note: Click Remind Me Later to not synchronize now but to display a notification the
next time Topaz Workbench is launched and there are updated settings to be
synchronized.
Note: Click Never to not be notified of connection or configuration changes when
Topaz Workbench is launched. To later change this choice, from the Window menu,
select Compuware> Enterprise Services, then select or clear the Disable
synchronization notification messages check box as needed.

3.

Select the remote HCI connections to be synchronized with CES. The following icons indicate the
connection changes that have occurred since the last synchronization:



indicates a connection that has been added in CES and will be available after
synchronization.
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indicates a connection that has been deleted from CES and will no longer be available after
synchronization.



indicates a connection that has been changed in CES and will be updated after
synchronization.

Note: There are no selections for the user to make regarding configuration settings,
only for host connection settings. All changes to configuration settings are included when
synchronization happens.
Note: Selecting a group check box indicates a desire to keep in sync with any new
connections that are later added to the selected connection group.
4.

Click Finish. All configuration settings—such as for Abend-AID, Fault Analytics, iStrobe—as well as any
selected host connection settings are synchronized. The results of the host connection synchronization,
such as the number of connections added, appears in the Synchronization Complete message box. The
host connections appear on the Host Connections preference page and in the Host Explorer tree.
Whenever Topaz Workbench is launched and updated host connections or configuration settings are
available, a notification box appears and contains a link to the Synchronize Remote HCI Connections
dialog box.

To manually synchronize host connection settings and configuration settings

1.

From the Window menu, select Preferences. The Preferences dialog box appears.

2.

Select Compuware > Enterprise Services.

3.

Click Sync. The Synchronize Remote HCI Connections dialog box appears.
Note: If the Compuware Enterprise Services (CES) server has been set up to require
user ID and password for authentication, the Compuware Enterprise Services Login
dialog box appears when Sync is clicked. However, this dialog box will not appear if the
user previously opted to save credentials or is already logged in for the current Topaz
Workbench session. After logging in, the Compuware Enterprise Services
Synchronization dialog box appears as described above. After logging in, the
Synchronize Remote HCI Connections dialog box appears as described above.

4.

Complete the dialog box as described above.

Topaz Workbench License
Topaz Workbench users can check out a license to enable Topaz Workbench functionality. By default, the checkout
period lasts 10 hours but can be changed. Refer to the Compuware Enterprise Services Administration online help for
information on changing the checkout period.
The Topaz Workbench license is validated whenever Topaz Workbench is launched, and manually when desired.
Refer to the Topaz Workbench Installation Guide for information on the initial license setup.
To address a license failure message when Topaz Workbench is launched

1.

On the Topaz Workbench License dialog box that appears, click Preferences. The Enterprise Services
page of the Preferences dialog box appears.

2.

In the URL field, enter the URL for Compuware Enterprise Services, then click Test Connection. If a
message appears indicating that the connection is not successful, click OK, enter a valid URL, then click
Test Connection again.

3.

Click OK. The Topaz Workbench License dialog box appears again.

4.

Click Checkout.

To set the URL for Compuware Enterprise Services
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1.

From the Help menu, select Topaz Workbench Licensing.
Note: If the Compuware Enterprise Services (CES) server has been set up to require
credentials for authentication, depending on the type of credentials required, a prompt to enter
credentials may appear. However, no prompt appears if the user previously opted to save
credentials or is already logged in for the current Topaz Workbench session.

2.

Click Preferences. The Enterprise Services page of the Preferences dialog box appears.

3.

In the URL field, enter the URL for Compuware Enterprise Services, then click Validate Connection. If a
message appears indicating that the connection is not successful, click OK, enter a valid URL, then click
Validate Connection again.

4.

Click OK.

To check the status of the license

From the Help menu, select Topaz Workbench Licensing. The Topaz Workbench License dialog box appears,
showing whether the product is licensed as well as when the license was checked out and when it expires.
Note: If the Compuware Enterprise Services (CES) server has been set up to require
credentials for authentication, depending on the type of credentials required, a prompt to enter
credentials may appear. However, no prompt appears if the user previously opted to save
credentials or is already logged in for the current Topaz Workbench session.
To renew the license checkout

1.

From the Help menu, select Topaz Workbench Licensing. The Topaz Workbench License dialog box
appears.
Note: If the Compuware Enterprise Services (CES) server has been set up to require
credentials for authentication, depending on the type of credentials required, a prompt to enter
credentials may appear. However, no prompt appears if the user previously opted to save
credentials or is already logged in for the current Topaz Workbench session.

2.

Click Renew. The current license is released and an attempt is made to check out another license. If a
failure message appears, resolve the reason for the checkout failure.

To resolve checkout failures

Checkout failures are caused by the following:

•
•
•
•
•

An inaccurate URL
An expired license
The web application no longer running
The server being down
All available licenses are in use

Resolve the cause of the failure and click Try Again.
To enable cloud licensing

A cloud license can be used to access licensed features in Topaz Workbench in situations in which a CES server is
not available to provide these features. If interested in leveraging Compuware's cloud licensing service for Topaz
Workbench's licensed features, contact your Compuware sales representative or contact Customer Solutions via the
Compuware Support Center.
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1.

To enable cloud licensing once Compuware indicates that it is available, from the Window menu, select
Preferences. The Preferences dialog box appears.

2.

Toggle open the Compuware node and select Enterprise Services.

Integration with Compuware Enterprise Services
3.

Select the Use Compuware cloud license service for Topaz Workbench licensing check box.

4.

Click OK.

Note: Compuware recommends, for long-term use in large deployments, that a CES server be installed for easier
administration of Topaz Workbench. When a CES server is available for licensing, the Use Compuware cloud
license service for Topaz Workbench licensing check box must be cleared so Topaz Workbench leverages the
CES server rather than the cloud service for licensing.
Note: An internet connection is required to connect to the cloud licensing service and the connection uses HTTPS
to encrypt the data transmitted. If a network proxy is required for internet access, from the Preferences menu, select
General>Network Connections. On the Network Connections preference page, select the appropriate HTTPS
proxy entry and click Edit. Complete the Edit Proxy Entry dialog box by entering the host and port for your proxy
server so Topaz Workbench can connect to the cloud licensing service.

Authenticating to Compuware Enterprise Services
If the Compuware Enterprise Services (CES) server has been set up to require credentials for authentication, the
Compuware Enterprise Services Login dialog box appears so that users can provide the required credentials to
connect to CES. For example, this might be required when requesting license checkout or synchronizing host
connection settings.
To authenticate to CES

1.

From the Window menu, select Preferences>Compuware>Enterprise Services. The Enterprise
Services page of the Preferences dialog box appears.

2.

After entering a valid URL, if a message regarding authentication appears below the URL field, click
Credentials. The type of security that is set up on CES appears below the URL field and the Compuware
Enterprise Services Login dialog box appears.

3.

If required, enter the credentials for logging into CES, then click OK.
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Import and Export Compuware Configuration Settings
The import and export wizards enable users to save and retrieve various resource settings and configurations to and
from the file system. Alternatively, Topaz Workbench's central administration functionality allows users to easily
synchronize host connection settings with Compuware Enterprise Services (CES). Topaz Workbench monitors these
settings, which are stored in CES, and notifies the user when changes have occurred so the user can synchronize to
the CES settings.
Note: To import and export Compuware Mainframe Projects, use the Compuware Mainframe Project Import/Export
Wizard.
To export resource configurations and settings

1.

From the Host Explorer's File menu, select Export. The Export dialog box appears.

2.

Select Compuware>Compuware Configuration Settings and click Next. The Export Compuware
Configuration Settings dialog box appears.

3.

Do one of the following:

•

To export all settings, click Export all.

•

To select specific settings to export, click Choose specific configuration settings to export. Then select
from the Configuration Settings box the specific settings to export.
Note: Selecting a setting in the tree displays a description of the item in the Description box.

4.
In the To directory field or by clicking Browse, specify the directory to which to export the configuration
settings.
5.
Select or clear the Overwrite existing files without warning check box, depending on whether an existing
file with the same name should be overwritten by the new file.
6.

Click Finish. The configurations settings are exported to the specified directory for later retrieval.

To import resource configurations and settings

1.

From the Host Explorer's File menu, select Import. The Import dialog box appears.

2.

Select Compuware>Compuware Configuration Settings and click Next. The Import Compuware
Configuration Settings dialog box appears.

3.

In the From directory field or by clicking Browse, specify the directory containing the exported configuration
folder and/or files you want to import.

4.

Do one of the following:

•

To import all settings, click Import all.

•

To select specific settings to import, click Choose specific configuration settings to import. Then
select from the Configuration Settings box the specific settings to import.

Note: Selecting a setting in the tree displays a description of the item in the Description box.
5.

Click Finish. The configurations settings are imported into Topaz Workbench.
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Compuware Preferences
All Topaz Workbench plug-in preferences are listed in the Preferences dialog box under the Compuware node.
Refer to the plug-in documentation for information on setting preferences for plug-ins.
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Fix Requests
Licensed iStrobe and Abend-AID users can access fix requests in Topaz in a variety of ways:

•
•

Users can import a launch configuration from a JIRA fix request. Refer to the Compuware Enterprise
Services online help for information on creating the JIRA issue.
Users can import a fix request file that was exported from iStrobe or from Abend-AID. From this imported fix
request file, a Mylyn task and/or Xpediter launch configuration can be created. Refer to the iStrobe online
help for information on exporting a fix request from iStrobe. Refer to the Abend-AID Web Browser Interface
help for information on exporting a fix request from Abend-AID.

Importing a Fix Request File from iStrobe or Abend-AID
Users can import a performance problem fix request file that was exported from iStrobe or an abend fix request file
that was exported from Abend-AID. From this imported fix request file, a Mylyn task and/or Xpediter launch
configuration can be created. Mylyn is a task management application that is shipped with Topaz Workbench. Refer
to the iStrobe online help for information on exporting a fix request from iStrobe. Refer to the Abend-AID Web
Browser Interface help for information on exporting a fix request from Abend-AID.
To import a fix request

1.

From the File menu, select Import. The Import dialog box appears.

2.

Toggle open the Compuware node and select Fix Request.

3.

Click Next. The Import a Fix Request wizard appears.

4.

In the File name field, type the path and filename of the file to be imported. Alternatively, click Browse and
navigate to and select the file. The Summary and Description fields populate with information from the
selected file.
Note: By default, fix request files have a .fxr extension, however it can be changed to
any file extension.

5.

Click Next. The Create Fix Request Artifacts page appears. By default, the Name field contains the
summary and event date and time from the imported file, however it can be renamed.

6.

From the Artifacts box, select the check boxes for the types of artifacts (a Mylyn task and/or an Xpediter
launch configuration) to be created:

•
•

Select Mylyn task to create a Mylyn task that describes the fix request.
Select Xpediter launch configuration to create an Xpediter launch configuration.

Note: If a fix request file does not contain all of the information that an artifact creator
needs, the check box for that artifact creator will be grayed out. For example, if the LPAR
value is missing from the file to be imported, the Xpediter launch configuration check box
will be grayed out.
7.

Optionally, select the Overwrite existing artifacts that don’t allow duplicate names to overwrite an
existing file with the same name if encountered.

8.

Click Finish.
Note: If an error is encountered, the Artifact Creation Results page appears. Click
Close.
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9.

Do one of the following:




If Mylyn task was selected above, the Task view and Task List view appear and give details about the
fix request. Refer to the Eclipse documentation for information on Mylyn and these views.
If an Xpediter launch configuration artifact was created, refer to the Topaz Workbench Xpediter/Eclipse
User Guide to complete the configuration.

Importing a Launch Configuration for a Fix Request
Users can use Compuware Enterprise Services to create a JIRA issue and an attached launch configuration file
containing the relevant fix request information. This file can then be imported into Topaz Workbench so the program
requiring a fix can be debugged. Refer to the Compuware Enterprise Services online help for information on creating
the JIRA issue and the associated launch configuration.
To import the launch configuration into Topaz Workbench

1.

In the JIRA issue, right-click the launch configuration attachment and select Save target as. The Save As
dialog box appears.

2.

Save the launch configuration.

3.

Launch Topaz Workbench.

4.

From the File menu, select Import. The Import dialog box appears.

5.

Select Run/Debug>Launch Configurations and click Next. The Import Launch Configurations dialog
box appears.

6.

In the From Directory field, enter the file location where the launch configuration is stored on the local file
system, or click Browse to navigate to the location. The selected directory and all subdirectories are listed in
the left column.

7.

Do any of the following:



8.

Click a directory or subdirectory name to display all of the launch configuration files (*.launch)
within that directory in the right column. Individual files can be selected when displayed in the
right column.
Select the directory's check box to select all of the configuration files contain in that directory.

Click Finish.

To open the launch configuration in Topaz Workbench

1.

In Xpediter/Eclipse, from the Run menu, select Debug Configurations. The Debug Configurations dialog
box appears.

2.

Toggle open the folder containing the launch to be opened.

3.

Select the debug configuration that was imported.

4.

If desired, click Debug to debug the launch configuration. Refer to the Compuware Xpediter/Eclipse User
Guide for more information on launch configurations.
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Compuware Diagnostic Tools
Topaz Workbench includes an on-demand diagnostic tool to help Compuware diagnose issues related to the usage
of these products. This tool does the following:

•
•

Provides a central point for enabling tracing for plug-ins and companion mainframe products
Produces a diagnostic report that is packaged in one file for diagnosis by Compuware

During problem resolution, Compuware Customer Support may request that the Compuware Diagnostic Tools be
used to capture diagnostic data. The Compuware Diagnostic Tools are reserved for issues opened with Compuware
Customer Support.
To generate a diagnostic report if the problem can be recreated

1.

From the Help menu, select Compuware Diagnostic Tools>Enable Diagnostic Tracing to enable
diagnostic tracing.

2.

Repeat the steps that led to the problem needing resolution.

3.

From the Help menu, select Compuware Diagnostic Tools>Generate Diagnostic Report. A diagnostic
report file is generated in the location specified in the Progress Information dialog box.

4.

Send the diagnostic report file to Compuware Customer Support for diagnosis.

To generate a diagnostic report when the problem cannot be recreated

1.

From the Help menu, select Compuware Diagnostic Tools>Generate Diagnostic Report. A diagnostic
report file is generated in the location specified in the Progress Information dialog box.

2.

Send the diagnostic report file to Compuware Customer Support for diagnosis.
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Product Assistance
Compuware provides assistance for customers with its documentation and Compuware Support Center.

Documentation
The product documentation set includes the following:

•
•

The Topaz Workbench Installation Guide provides information on installation.
The online help provides descriptions of the product operating procedures and reference information.

The release notes and installation guide can be found at https://go.compuware.com.
Online books are provided in PDF format, and require a supported version of Adobe Reader to view them. The free
Adobe Reader is available on the Adobe web site at http://www.adobe.com.
If you cannot locate the information you need, or the information is not clear, please let us know by contacting
Customer Solutions.

Compuware Support Center
Visit the Compuware Support Center, https://go.compuware.com, to find product documentation, knowledge articles,
and other technical resources. You can open a case with the Customer Solutions team, order products, and much
more.
Contact Customer Solutions by phone:

•
•

USA and Canada: 1-800-538-7822 or 1-313-227-5444.
All other countries: Contact your local Compuware office. Contact information is available
at https://go.compuware.com.

Please gather the following information before calling Compuware's 24-hour telephone support:

•
•
•
•
•

The name, release number, and build number of your product. This information is displayed in the About
dialog box.
Installation information including installed options, whether the product uses local or network databases,
whether it is installed in the default directories, whether it is a standalone or network installation, and
whether it is a client or server installation.
Environment information, such as the operating system and release on which the product is installed,
memory, hardware and network specification, and the names and releases of other applications that were
running when the problem occurred.
The location of the problem within the running application and the user actions taken before the problem
occurred.
The exact application, licensing, or operating system error messages, if any.

Visit Compuware on the web at http://www.compuware.com for additional product information.
Compuware also offers user communities, online forums to collaborate, network, and exchange best practices with
other Compuware solution users worldwide. Go to http://groups.compuware.com/ to join.

21

Index
C

iStrobe, importing fix request from 17

companion product compatibility 7

L

Compuware Diagnostic Tools 19

license, Topaz 10

Compuware preferences 15

M

D

Mylyn 17

Diagnostic Tools, Compuware 19

P

F

preferences, Compuware 15

fix request 17
I
importing fix request 17

problem, importing fix request 17
product compatibility, companion product 7
T
Topaz license 10

23

